Score history is partially loading
Incident Report for SecurityScorecard External
Resolved
This incident has been resolved.
Posted Jun 16, 2021 - 14:58 UTC
Update
We are continuing to investigate this issue.
Posted Jun 16, 2021 - 14:26 UTC
Investigating
We are currently investigating the issue.
Posted Jun 16, 2021 - 14:25 UTC
This incident affected: Ratings Platform.