Security Scorecard Platform is experiencing log in issues!
Incident Report for SecurityScorecard External
Resolved
This incident has been resolved.
Posted Mar 01, 2021 - 21:43 UTC
Monitoring
We are monitoring the platform right now.
Posted Mar 01, 2021 - 21:03 UTC
Investigating
We are currently investigating this issue.
Posted Mar 01, 2021 - 20:46 UTC
This incident affected: Ratings Platform and Atlas Platform.