Maintenance taking longer then expected!
Incident Report for SecurityScorecard External
Resolved
This incident has been resolved.
Posted Nov 01, 2020 - 23:39 UTC
Investigating
The Atlas Maintenance is still underway and taking longer than expected.
Posted Nov 01, 2020 - 17:56 UTC
This incident affected: Atlas Platform.