Evidence Locker Issue

Incident Report for SecurityScorecard External

Resolved

The issue has now been resolved.
Posted Dec 01, 2025 - 17:13 UTC

Monitoring

Evidence Locker issue has been addressed and we are monitoring the results.
Posted Dec 01, 2025 - 16:29 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 01, 2025 - 15:45 UTC

Investigating

Evidence Locker Uploads may not be available to all users
Posted Dec 01, 2025 - 15:29 UTC
This incident affected: Ratings Platform.