Scorecard page load error

Incident Report for SecurityScorecard External

Resolved

This incident has been resolved.
Posted May 25, 2026 - 14:00 UTC

Monitoring

A fix has been implemented, and we are seeing scorecards load successfully. We will continue to monitor the system closely to ensure stability before resolving the incident completely.
Posted May 25, 2026 - 12:44 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 25, 2026 - 12:29 UTC

Investigating

We are investigating an issue where users receive a "Page Load Error" when attempting to open scorecards. Our engineering team is actively working to identify the cause and restore full functionality.
Posted May 25, 2026 - 12:20 UTC
This incident affected: Ratings Platform.