Some Platform Services Degraded Related to AWS Incident

Incident Report for SecurityScorecard External

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 21:49 UTC

Monitoring

Critical functionality is restored. There may be potential delays in certain data updates.
Posted Oct 20, 2025 - 19:42 UTC

Update

We are continuing to experience service disruptions due to the ongoing AWS outage in the US-EAST-1 region.
Our team is monitoring the situation closely and working on mitigations where possible. We will provide further updates as AWS restores services in the affected region.
Posted Oct 20, 2025 - 15:27 UTC

Identified

We are currently experiencing degraded performance with the Ratings Platform due to an ongoing incident with AWS in the US-EAST-1 region. This is impacting page load times and our reporting services. We are monitoring the situation and will provide updates as more information becomes available from AWS.
Posted Oct 20, 2025 - 12:31 UTC
This incident affected: Ratings Platform.